EGEsoll - сборник решений задач из ЕГЭ

Задача 6 кластеризация

Фрагмент звёздного неба спроецирован на плоскость с декартовой системой координат. Учёный решил провести кластеризацию полученных точек, являющихся изображениями звёзд, то есть разбить их множество на NN непересекающихся непустых подмножеств (кластеров), таких что точки каждого подмножества лежат внутри прямоугольника со сторонами длиной HH и WW, причём эти прямоугольники между собой не пересекаются. Стороны прямоугольников не обязательно параллельны координатным осям.

Гарантируется, что такое разбиение существует и единственно для заданных размеров прямоугольников.

Будем называть центром кластера точку этого кластера, сумма расстояний от которой до всех остальных точек кластера минимальна. Для каждого кластера гарантируется единственность его центра. Расстояние между двумя точками на плоскости A (x1,y1)A (x1​,y1​) и B(x2,y2)B(x2​,y2​) вычисляется по формуле:

d(A,B)=(x2−x1)2+(y2−y1)2d(A,B)=(x2​−x1​)2+(y2​−y1​)2

В файле A хранятся данные о звёздах двух кластеров, где H=6,5H=6,5, W=4,5W=4,5 для каждого кластера. В каждой строке записана информация о расположении на карте одной звезды: сначала координата xx, затем координата yy. Значения даны в условных единицах. Известно, что количество звёзд не превышает 1000.

В файле B хранятся данные о звёздах трёх кластеров, где H=6,5H=6,5, W=5W=5 для каждого кластера. Известно, что количество звёзд не превышает 1000. Структура хранения информации о звездах в файле B аналогична файлу А.

Для файла А определите координаты центра каждого кластера, затем найдите два числа: P1P1​ — минимальное расстояние от точки с координатами (5,0; 6,0) до центра кластера, и P2P2​ — максимальное расстояние от этой же точки до центра кластера.

Для файла B определите координаты центра каждого кластера, затем найдите два числа: Q1Q1​ — в кластере с наибольшим количеством точек число таких точек, которые находятся на расстоянии не более 1,5 от центра кластера, и Q2Q2​ — в кластере с наибольшим количеством точек число таких точек, которые находятся на расстоянии не более 0,95 от центра кластера.

Гарантируется, что во всех кластерах количество точек различно.

В ответе запишите четыре числа: в первой строке — сначала целую часть произведения P1×10 000P1​×10000, затем целую часть произведения P2×10 000P2​×10000; во второй строке — сначала Q1Q1​, затем Q2Q2​.

Download File 1

Добавлено: 27.04.26 15:59

Перейти к решению

Решение

Решение на языке Python:

from math import dist
s = open("embed.txt")
data = []
for line in s:
    data.append([float(x) for x in line.split()])
print(len(data))

def get_cl(p0):
    cl = [p for p in data if dist(p, p0) < 1]
    if cl:
        for p in cl:
            data.remove(p)
        next_cl = [get_cl(p) for p in cl]
        cl += sum(next_cl, [])
    return cl

cls = []
while data:
    cl = get_cl(data[0])
    print(len(cl))
    cls.append(cl)

def centroid(cl):
    m = []
    for p in cl:
        sm = sum(dist(p, p0) for p0 in cl)
        m.append([sm, p])
    return min(m)[1]

centroids = [centroid(cl) for cl in cls]
d = [dist(p, [5.0, 6.0]) for p in centroids]
p1 = int(min(d) * 10000)
p2 = int(max(d) * 10000)
print(p1, p2)
print("="*20)
"========================================================="
s = open("embed.txt")
data = []
for line in s:
    data.append([float(x) for x in line.split()])
print(len(data))

cls = []
while data:
    cl = get_cl(data[0])
    print(len(cl))
    cls.append(cl)

centroids = [centroid(cl) for cl in cls]
q1 = len([p for p in cls[0] if dist(p, centroids[0]) <= 1.5])
q2 = len([p for p in cls[0] if dist(p, centroids[0]) <= 0.95])
print(q1, q2)

Ответ: б) 398 278

Автор - IdealniyAriets

Объяснение

None

Назад